Author Topic: Can you have the game always run in Dx11?  (Read 3089 times)

Offline Hoja Lateralus

  • Member
  • Salutes: 135
    • [ψ꒜]
    • 45 
    • 45
    • 23 
    • View Profile
Can you have the game always run in Dx11?
« on: September 21, 2016, 09:04:30 pm »
I'm just using the desktop shortcut and I think it always run in Dx9 and I can find no option for global setting or Dx11 shortcut.

Offline Inkjet

  • Muse Games
  • Salutes: 15
    • [Muse]
    • 45 
    • 45
    • 45 
    • View Profile
Re: Can you have the game always run in Dx11?
« Reply #1 on: September 22, 2016, 10:11:34 pm »
There may be a launch option setting for it.

I'd also like to know.

Offline Atruejedi

  • Member
  • Salutes: 64
    • [❤❤❤]
    • 45 
    • 45
    • 45 
    • View Profile
Re: Can you have the game always run in Dx11?
« Reply #2 on: September 22, 2016, 10:33:08 pm »

Offline Hoja Lateralus

  • Member
  • Salutes: 135
    • [ψ꒜]
    • 45 
    • 45
    • 23 
    • View Profile
Re: Can you have the game always run in Dx11?
« Reply #3 on: September 23, 2016, 09:50:10 am »
Did anybody e-mail Muse about it or should I do it? We need answers.

Offline Schwalbe

  • Member
  • Salutes: 177
    • [ψ꒜]
    • 45 
    • 45
    • 45 
    • View Profile
Re: Can you have the game always run in Dx11?
« Reply #4 on: September 23, 2016, 10:13:04 am »
Did anybody e-mail Muse about it or should I do it? We need answers.

DX11 was an inside job

Offline Watchmaker

  • Muse Games
  • Salutes: 55
    • [Muse]
    • 28 
    • 26
    • 17 
    • View Profile
Re: Can you have the game always run in Dx11?
« Reply #5 on: September 23, 2016, 02:56:17 pm »
Add "-force-d3d11" to your launch options.

Offline Inkjet

  • Muse Games
  • Salutes: 15
    • [Muse]
    • 45 
    • 45
    • 45 
    • View Profile
Re: Can you have the game always run in Dx11?
« Reply #6 on: September 23, 2016, 06:13:44 pm »
Awesome! Thanks :)

Offline Atruejedi

  • Member
  • Salutes: 64
    • [❤❤❤]
    • 45 
    • 45
    • 45 
    • View Profile
Re: Can you have the game always run in Dx11?
« Reply #7 on: September 23, 2016, 06:55:53 pm »
Add "-force-d3d11" to your launch options.

Doesn't work for me. Tried it without quotes and with quotes.

Can anybody else report success or failure?

Offline Fynx

  • Member
  • Salutes: 30
    • [Rydr]
    • 45 
    • 45
    • 45 
    • View Profile
Re: Can you have the game always run in Dx11?
« Reply #8 on: September 24, 2016, 12:16:11 pm »
Seems to be working for me.

Not that I'm fully confident it's actually dx11, but it seems so.

Offline Inkjet

  • Muse Games
  • Salutes: 15
    • [Muse]
    • 45 
    • 45
    • 45 
    • View Profile
Re: Can you have the game always run in Dx11?
« Reply #9 on: September 24, 2016, 06:54:58 pm »
It doesn't work from the steam options, you have to make a shortcut. Launching from steam still shows the options.

Offline Atruejedi

  • Member
  • Salutes: 64
    • [❤❤❤]
    • 45 
    • 45
    • 45 
    • View Profile
Re: Can you have the game always run in Dx11?
« Reply #10 on: September 24, 2016, 08:06:36 pm »
It doesn't work from the steam options, you have to make a shortcut. Launching from steam still shows the options.

Ah. Bah. No point, then.

Offline Watchmaker

  • Muse Games
  • Salutes: 55
    • [Muse]
    • 28 
    • 26
    • 17 
    • View Profile
Re: Can you have the game always run in Dx11?
« Reply #11 on: September 26, 2016, 03:41:33 pm »
Adding that option (without quotes) to the launch options in Steam should cause the first/default entry in the launch menu to launch you in DX11 mode.  At least, it does for me.

If you're unsure what mode you're in, check your client log (output_log.txt).  You should see one of the following in the first couple of lines:

Quote
Forcing GfxDevice: Direct3D 11
Quote
Forcing GfxDevice: Direct3D 9

...followed later by some more detailed hardware information like so:

Quote
Direct3D:
    Version:  Direct3D 9.0c [aticfx32.dll 8.17.10.1452]
    Renderer: AMD Radeon HD 7800 Series
    Vendor:   ATI
    VRAM:     2027 MB (via DXGI)
    Caps:     Shader=30 DepthRT=1 NativeDepth=1 NativeShadow=1 DF16=1 INTZ=1 NULL=1 RESZ=1 SlowINTZ=1

If both references to Direct3D say 11 rather than 9, you're in DX11 mode.

Note that if for some reason Unity doesn't detect your system as supporting DX11, it will fall back on DX9 regardless of what you specify.  (If anything, I've seen it give false positives rather than false negatives; there are a few reported cards/drivers that "support" DX11 and then crash immediately because they don't actually.)

Offline Atruejedi

  • Member
  • Salutes: 64
    • [❤❤❤]
    • 45 
    • 45
    • 45 
    • View Profile
Re: Can you have the game always run in Dx11?
« Reply #12 on: September 26, 2016, 05:37:02 pm »
Adding that option (without quotes) to the launch options in Steam should cause the first/default entry in the launch menu to launch you in DX11 mode.  At least, it does for me.

Yeah, weird. Checked the output log. I'm definitely in Direct X11 mode and capable of running it (I choose it over 9 consistently), but it won't "stick" for me. Even when I set the launch option, it still prompts me to choose which option I want when I launch the game. Oh well. Just two extra clicks ;)